Skip to main content
  1. Home
  2. Docs
  3. General Information
  4. System requirements

System requirements

To develop and run body-tracking applications using the LightBuzz SDK, ensure your computer runs on the proper hardware. Our engineers have managed to keep the requirements as low as possible while maintaining incredible performance. As a rule of thumb, remember that the better the specs, the higher the performance.

Hardware specifications

Windows

When developing Windows applications, you need a modern computer with a decent graphics chip. All major hardware providers are supported, including AMD, Intel, and NVIDIA. Use CPU Benchmark and GPU Benchmark to ensure your processor and graphics card are above the following minimum specs.

Minimum
Processor (CPU)Intel 7th Gen i5
AMD Ryzen 5 5600G
Graphics Card (GPU)NVIDIA GeForce GTX 960
AMD Radeon RX 580
Intel Iris Xe
RAM8 GB
DirectXDirectX 11
Operating SystemWindows 10
Windows 11

macOS

On macOS, the LightBuzz SDK supports both Intel and Apple Silicon-based computers.

Minimum
Processor (CPU)Apple M1 8-Core
Intel Core i5 Quad-Core
Graphics Card (GPU)Apple M1 8-Core
Intel Iris Plus
RAM8 GB
Operating SystemmacOS 11 Big Sur

Ubuntu Linux

On Ubuntu, the LightBuzz SDK works with NVIDIA graphics chips only.

Minimum
Processor (CPU)Intel 7th Gen i5
AMD Ryzen 5 5600G
Graphics Card (GPU)NVIDIA GeForce GTX 960
RAM8 GB
Operating SystemUbuntu 18.04 LTS
Ubuntu 20.04 LTS
  • An Intel CPU is required for hardware acceleration in CPU mode.
  • An NVIDIA CUDA GPU is required for hardware acceleration in GPU mode.

iOS

We support iPhone and iPad devices with A11 Bionic or later.

Minimum
ChipsetApple A11 Bionic+
Apple M1+
Operating SystemiOS 14+

Android

On Android, you need a device with a Snapdragon 845 chipset or equivalent or better.

Minimum
ChipsetSnapdragon 845+
Google Tensor+
Adreno 630+
Operating SystemAndroid 10+
(Android API level 29+)

Software

To develop your applications, we recommend the following tools.

UnityUnity 2019 LTS
Unity 2020 LTS
Visual StudioVisual Studio 2019
Visual Studio 2022
Visual Studio for Mac
Visual Studio Code
XCodeXCode 12+

How can we help?